VB generation from Domain Model doesn't Work

Aug 14, 2008 at 1:15 PM
Edited Aug 14, 2008 at 2:12 PM
First of all , Congratulations for your beautiful piece of code, it is a real pleasure to discover this framework :-)

I tried to generate vb classes and it doesn't seem to work ,
i tried with the help of the custom generator within Visual studio 2005 and with the Domain.exe program.
i tried with this example :

-----------------------------------------------------------------------
    <Class name ="contact" >
      <Property name ="nom" type ="System.String"/>
      <Property name="prenom" type ="System.String"/>
      <Property name ="Age" type ="System.int32"/>
    </Class>
    <Class name="Customer">
      <Property name="Name" type="System.String" />
    </Class>

    <Class name="Order">
      <Property name="Amount" type="System.Int32" />
    </Class>

    <Relationship type="composition">
      <Parent name="Customer" role="Customer" multiplicity="1" />
      <Child name="Order" role="Orders" multiplicity="*" />
    </Relationship>
-----------------------------------------------------------------------


each time it only generate this text :

Imports System
Imports System.Reflection
Imports System.Collections
Imports System.Collections.Generic
Imports USS = Evaluant.Uss
Imports Evaluant.Uss.ObjectContext

'///////////// Code for Visual 2005 VB.NET /////////////////////

but all is generated if I choose the C# generation


Any clue ??





Coordinator
Aug 14, 2008 at 3:33 PM
More than a clue, the reason. I think the VB code generation must be really out of date as I have seen nobody using it yet.
I add this request in the Issue Tracker. Won't be very long before having it to work.

Sebastien
Aug 14, 2008 at 7:44 PM
oops , i must be the last vbnet developer :-) sad but c'est la vie :)
so Thank you for your quiick response